Sie sind nicht angemeldet.

1

Dienstag, 24. Januar 2012, 15:49

Firmware ab 1.03x, für die V07a, V08, X1, X1CAN, X3

Da diese Stände aus dem gleichen source code erzeugt werden, möchte ich diese wie beim letzten mal für den download zusammenfassen. Die Änderungen können der changelog entnommen werden.

Übersicht der Änderungen (changelog)

bootloader für den 1284P 0.87 ( für V07a, V08 )

Firmware V07 1.03b (Version vom 22.06.2012 20:15)
Firmware V07 1.03c (Version vom 3.1.2013)
Firmware V07 1.03d (Version vom 2.2.2014)

Firmware V08 1.03a (Version vom 17.04.2012)
Firmware V08 1.03b (Version vom 24.06.2012)
Firmware V08 1.03c (Version vom 05.01.2013)

bootloader ATmega 128 10k, 0.87 ( für X1 )

Firmware X01 , AWL 10k, 1.03b (Version vom 09.07.2012)
Firmware X01 , AWL 10k, 1.03c (Version vom 20.08.2012)

Firmware X01CAN , AWL 10k, 1.03b (Version vom 09.07.2012)
Firmware X01CAN , AWL 10k, 1.03c (Version vom 05.02.2012)

bootloader ATXmega 128A1, 0.87

Firmware X3 , 1.03b (Version vom 04.07.2012)
Firmware X3 , 1.03c (Version vom 12.12.2013)

2

Freitag, 14. August 2015, 09:19

Temperatur

Hallo,
ich habe eben die Firmware X3 1.03c aufgespielt. Bekomme aber Temperaturwerte von 70-80° angezzeigt. Kann man das ändern? Oder soll ich die andere Firmware nehmen? Fühler DS18B20

Gruß
Lorenz

3

Mittwoch, 19. August 2015, 09:39

Hallo Lorenz,
ich war im Urlaub und kann daher erst jetzt antworten.

Die Firmware müsste soweit passen. Was ist die tatsächliche Temperatur?

Für den one wire bus habe ich ein Dokument in dem dieser Bausteine mit beschrieben ist.

Gruß Reinhold

4

Mittwoch, 19. August 2015, 17:35

Hi Reinhold,
die Temperatur liegt bei ca. 20°. Ich hab 6 sensoren dran zeigen alle zwischen 70-80°.

Gruß
Lorenz

5

Sonntag, 23. August 2015, 16:36

Hallo Lorenz,
ich kann mir das noch nicht so richtig vorstellen wie die 70 bis 80 °C zusammen kommen.

Die Temperatur wird vom DS18B20 digital übertragen. Ich lese diese aus und stelle den Wert dann zur Verfügung.

Falls der DS18B20 nicht getriggert wird, liegt der Temperaturwert in diesem Temperaturbereich. Aber vorstellen kann ich mir das momentan auch nicht.

Ist der Temperaturwert immer genau der gleiche oder ändert sich dieser beim Anfassen der Temperturfühler ?

Da ich momentan im Dunklen tappe, muss ich es mit Fragen versuchen.

Gruß Reinhold

6

Montag, 24. August 2015, 14:02

Hallo Reinhold,
das passiert wenn ich mehr wie 3 Fühler anschließe. Mit 3 geht es noch
Gruß
Lorenz

7

Montag, 24. August 2015, 15:02

Hallo Reinhold,
das passiert wenn ich mehr als 3 Fühler anschließe. Mit 3 geht es noch.
Pro Eingang
Gruß
Lorenz

8

Montag, 24. August 2015, 17:21

Hallo Lorenz,
diese Information war wichtig. Die DS18B20 Sensoren werden mit einem pull up auf 5V gezogen und mit einem Portpin des ATMega gesteuert. Der Bus wird durch die Sensoren und durch die Leitung belastet. In diesem Fall sieht es so aus als kommt die Information des ATMega bei den Sensoren nicht mehr korrekt an. Das Schalten gegen GND sollte der ATMega gut hinbekommen. Vielleicht ist die Hi Flanke mit dem pull up Widerstand zu träge. Eine Reduzierung des Widerstands auf 2,7k könnte hier hilfreich sein.
Welche Art von Leitung wurde für den Anschluss der Sensoren verwendet ? ( Länge und Leitungstyp sind entscheidend )

Gruß Reinhold

9

Freitag, 28. August 2015, 15:54

Hi Reinhold,
ich habe ca. 0,7m dran. Sollte nicht zu lang sein. Zwei Phasen angklemmt. Orginal 3Phasenkabel über eine kleinen Adapter mit mehreren Klemmen. Ich kann ja mal einen Widerstand drauflegen.
Gruß
Lorenz

10

Montag, 7. September 2015, 07:50

Hallo Reinhold.
es läuft nun.
Das Netzteil war zu schwach. Mit mehr Spannung geht es. Kann man eigentlich Schaltpläne von der V08 nach X3 kopieren?

Gruß
Lorenz

11

Montag, 7. September 2015, 20:22

Hallo Lorenz,
toll dass der Fehler gefunden wurde. Die Schaltpläne sind bis auf weinige Bausteine bei allen Varianten gleich. Für die einzelnen Varianten gibt es jedoch einen Grundschaltplan. Dieser wurde speziell für die Version erstellt. Dann kommen die Bausteine und die Verbindungen hinzu. Solle ein Teil im Schaltplan kopiert werden, geht das mit Bereich markieren und ausschneiden. Danach den neuen Schaltplan öffnen und einfügen.

Gruß,
Reinhold

Ähnliche Themen